JDBC Data Source creation using WLST - Weblogic

This is a discussion on JDBC Data Source creation using WLST - Weblogic ; I seem to a have a problem using weblogic 9.2 and creating data source via = wlst. The data source seems to get created ok but the jndi name is differne= t from what I supplied. Weblogic seems to prepend ...

+ Reply to Thread
Results 1 to 2 of 2

JDBC Data Source creation using WLST

  1. Default JDBC Data Source creation using WLST

    I seem to a have a problem using weblogic 9.2 and creating data source via =
    wlst. The data source seems to get created ok but the jndi name is differne=
    t from what I supplied. Weblogic seems to prepend CP- to the name that I pr=
    ovide. This causes problems as my software cannot look it up. Why is this =
    happening?=20

    If I use console directly to create data source it works fine and the jndi =
    name is correct.

  2. Default Re: JDBC Data Source creation using WLST

    This worked @ my side:


    cd('/JDBCSystemResources/'+coName+'/JDBCResource/'+coName)
    set('Name',coName)
    cd('/JDBCSystemResources/'+coName+'/JDBCResource/'+coName+'/JDBCDataSourc=
    eParams/'+coName)
    set('JNDINames',jarray.array([String(coName)], String))
    cd('/JDBCSystemResources/'+coName+'/JDBCResource/'+coName+'/JDBCDriverPar=
    ams/'+coName)
    set('Url',url)
    set('DriverName',DRIVER )
    set('Password',CONNECTIONPOOLPASSWORD)

    --
    Schelstraete Bart
    bart@schelstraete.org
    http://www.schelstraete.org
    http://www.linkedin.com/in/bschelst

+ Reply to Thread