No Trusted Certificate???/ - Weblogic

This is a discussion on No Trusted Certificate???/ - Weblogic ; Hi I tried to implement SSL by generating keystores. When the server is starte= d i see the info. below... <No trusted certificates have been loaded. Server will not trust to any = certificate it receives.> Is this any concern??? ...

+ Reply to Thread
Results 1 to 3 of 3

No Trusted Certificate???/

  1. Default No Trusted Certificate???/

    Hi

    I tried to implement SSL by generating keystores. When the server is starte=
    d i see the info. below...

    <No trusted certificates have been loaded. Server will not trust to any =
    certificate it receives.>


    Is this any concern??? Ifso what should i do to overcome this.

    <Aug 4, 2004 12:04:29 AM EDT> <Notice> <Security> <BEA-090170> <Loading the=
    private key stored under the alias serverkey from the JKS keystore file /b=
    ea_home/OBSOON/OBSOON_WLS_DM/ObsoonDomain/serverkeystore.>
    <Aug 4, 2004 12:04:29 AM EDT> <Notice> <Security> <BEA-090171> <Loading the=
    identity certificate stored under the alias serverkey from the JKS keystor=
    e file /bea_home/OBSOON/OBSOON_WLS_DM/ObsoonDomain/serverkeystore.>
    <Aug 4, 2004 12:04:35 AM EDT> <Notice> <Security> <BEA-090169> <Loading tru=
    sted certificates from the JKS keystore file /bea_home/OBSOON/OBSOON_WLS_DM=
    /ObsoonDomain/serverkeystore.>
    <Aug 4, 2004 12:04:35 AM EDT> <Warning> <Security> <BEA-090172> <No trusted=
    certificates have been loaded. Server will not trust to any certificate it=
    receives.>=20
    <Aug 4, 2004 12:04:36 AM EDT> <Notice> <WebLogicServer> <BEA-000331> <Start=
    ed WebLogic Admin Server "ObsoonServer" for domain "ObsoonDomain" running i=
    n Development Mode>
    <Aug 4, 2004 12:04:36 AM EDT> <Notice> <WebLogicServer> <BEA-000360> <Serve=
    r started in RUNNING mode>
    <Aug 4, 2004 12:04:36 AM EDT> <Notice> <WebLogicServer> <BEA-000355> <Threa=
    d "ListenThread.Default" listening on port 7001, ip address *.*>
    <Aug 4, 2004 12:04:36 AM EDT> <Notice> <WebLogicServer> <BEA-000355> <Threa=
    d "SSLListenThread.Default" listening on port 7002, ip address *.*>

    thanks
    Jay

  2. Default Re: No Trusted Certificate???/

    This should be a concern only in the following scenarios

    1)If you are making a outgoing ssl call from within weblogic server (say fr=
    om jsp/servlet/webapp)

    OR=20
    2)if you are using 2 way ssl

    If youw ant to get rid of this mesaage just configure a keystore with trust=
    ed certificates (example: something like jdks cacerts ) It seems to me that=
    the keytsore file
    serverkeystore may not have any trusted root certificates in it

  3. Default Re: No Trusted Certificate???/

    I generated serverketstore using the keytool.

    keytool -genkey -keysize 1024 -keyalg RSA -dname "cn=3Djay.123.com, ou=3DWS=
    , o=3DJAY,c=3DUS" -alias serverkey -keypass serverpass -keystore serverkeys=
    tore -storepass webservice
    keytool -selfcert -keystore serverkeystore -alias serverkey -storepass webs=
    ervice -keypass serverpass

    Dont know how to make it a trusted certificate???
    =20
    Thanks
    Jay

+ Reply to Thread